Why can't I edit my comments or posts?


He has contacted the front office waiting on an answer



Not really a big deal for me either way. Just makes me make more posts then if I can edit if I forgot something. I wasn’t the one that started this thread, I was just responding to it.


I’m having the same problem…I could edit posts until a few days ago


That doesn’t work for me≥ When I hit the 3 dots, it only gives me the options to, share, flag, bookmark, or delete. There is no little pencil for editing. I have always been able to edit my comments on both of my posts until a couple of days ago and now I can’t. [quote=“garrigan62, post:14, topic:11564”]
. but it only appear’s after you hit reply by clicking those 3 dots you should be able to edit you last post…

Hitting reply only brings up the reply box. Unless you mean it only appears after you have posted your comment by hitting reply. :slight_smile:



ILGM free forum is setup on a “trust” level based system, to weed out abusive members and spammers. As you use the forum more, this level will go up.

Currently your membership is on the first level. This would limit your permissions and could very well be the reason you can’t edit posts. I highly recommend giving/receiving as many “likes” as you can.

Check out your profile, under the “badges”, and see what’s required to obtain more achievements.

Hope this helps…


I have received the Editor badge and have edited many of my comments. So I don’t think that’s the problem. :slight_smile:


@Lornakins first off love the new icon very cute pic
@garrigan62 I was speaking with @WillyJ yesterday he had same issue
I’ve been fine myself


Thanks, CB. That is a pic of my little pomeranian that I had for 14 years. I lost her her to sudden heart failure in Nov of 2015. She was the light of my life and I haven’t gotten over losing her yet. I was devastated. :cry:

So apparently, there are several others having the editing problem.


Sorry to hear that @Lornakins
I had a Pomeranian years ago cute little buggers they are lol


Here is my theory of what happened. As newbies we weren’t supposed to have the editing option to start with, but we did. They have now updated something in the permissions for our level that now is working as intended. Maybe?


But you get the Editor badge after you have edited a couple of times, and I had gotten the Editor badge already for that reason. So it would be odd to lose it now.


Try backing out and restarting you should have it they don’t take away the edit option lol


It gave me my editor badge 9 days ago.


I tried that already, a couple of times and it didn’t make any difference. In fact, I tried that first thing, because I know that can solve a lot of issues, but not this time.


Lol :joy: ok was just a thought


@Lornakins Got their badge 22 days ago.


And if I could edit my posts I wouldn’t have to keep making so many extras? LMAO


Yeah, I got mine quite a while back when I was brand new and when posting a reply, the box came up telling me that I should edit my other comment and tag those involved instead of replying to each one.


You don’t see the little pencil lower left side of post ?


Lower left?? It is usually under the 3 dots on the lower right. I never see anything on the lower left.