What's going on w/ my plant

Question from a fellow grower:

temp is 72 , soil ph is 1.3, humidity is 45. lighting is 12 on and 12 off

plants is whitewillow i bought from you with you fertilizer packet.

last night when watering ph was 1.3 plant was vibrante and green and strong no cluring of leaver of discoloring.

2 Likes

Ph should be around 6.5 if you are in soil, if soil what brand, how often are you watering?

1 Like

Welcome. First thing I Would verify my pH meter In a clean new 7 solution. And if pH is that low. Work to get it back in range. As tinman mentioned How often are you watering? My first thoughts over-watering. Good luck.

1 Like

I’m guessing the 1.3ph is a mistype
That looks just like what I had on 3-4 plants last grow…they all died a quick and horrible death. My only conclusion at that time and now was root nematodes.
They looked like this and it happened within a very short time like yours.


I tried flushing them with water then with Azamax and water mix then Hydrogen Peroxide water mix and so on and nothing worked.
I’m not saying it is root nematodes but that’s the only thing I came up with. Also it was right after I mixed up some Alaskan Fish Fertilizer 5-1-1 and fed them so not sure if that went bad or what but I don’t use that stuff anymore.

On a positive note another one had that same look at the same time but only partial like yours looks and it ended up recovering on its own and I did harvest her.

3 Likes

It’s not 1.3 on ph. That would burn thru your hand. What size pot are those? Recalibrate your ph meter. Sulfuric acid is 2.75 ph, just saying

3 Likes