Rusty spots on leaves

From a fellow grower:

I have these little rust spots on the leafs of one plant…none of the others in the same room have them…are they the rust mites ? or did I over feed it…its one of the sour D.

Two 400 watt grow lights an my back deck are my light sources…using Earth Juice Grow an Bloom…spots appeared about a week ago.


Is that white on those leaves…let us know if you could… get us a better pic say a closeup if you could.

Thanks

Will

I’m having the very same issue. Has anyone been able to identify what these ‘rust’ spots are?

This post was flagged by the community and is temporarily hidden.

PH is at a six (6), all other factors within limits (grow room, CFL, soil, temp, humidity) feeding judiciously with 5-20-5 (Bloom Boost MG). Don’t recognize the term “swing”? Could this be rust? If so - Treatment?

@ClaireILGM, @JohnCoffee

There’s not a lot of info that you posted here (pH, medium, feed schedule, etc…), but at first glance, I say Cal/Mag deficiencies.

2 Likes

This post was flagged by the community and is temporarily hidden.

1 Like

On the other hand there are growers that swear by MG. It’s a mixed bag in concern to opinions and the use of MG. Thanks.

This post was flagged by the community and is temporarily hidden.

1 Like

Fortune 500 should not be allowed to dictate the direction of where the cannabis industry ends up. I don’t support GH after the buyout or any other big business company like Scotts Brand.

1 Like

This post was flagged by the community and is temporarily hidden.

3 Likes

This post was flagged by the community and is temporarily hidden.

2 Likes

[quote=“pigSquishy, post:13, topic:4933”]
as little as a week I have seen results[/quote]

Recently started RAW NPK , Same results

1 Like

This post was flagged by the community and is temporarily hidden.

1 Like

Yes its really amazing so far. Had a Nitrogen Def used Nitrogen and
Yucca Foliar and seemed to green up overnight, actually so much so
I was expecting a crash the other way but she is doing just fine. Used
the Full Up & Kelp with a feed and on the next feeding I put in 850 ppm
(20 cups in / run-off 4 cups 20%) and found my ppm at Run-Off to be
895ppm so she actually pulled up nearly all of the previous feeding.

So far only good things to report

2 Likes

This post was flagged by the community and is temporarily hidden.

2 Likes