Help identify what's wrong


#1

Tryin to figure out what is wrong with it there is spoting on some of the leafs it’s my first hydro grow and I’m not sure what it is. And some of the new growth looks funny any advice or suggestions would be appreciated. When I get a min I’ll load all my other data


#2

Are you supplementing with Cal Mag?

http://www.thctalk.com/cannabis-forum/showthread.php?19873-Plant-Problems-Deficiencys-(Pics!)


#3

right on man that was awesome piece of information. I am using Cal Mag. It might be a zinc it’s affected new growth on all the side branching starting to come out. There only 3 weeks and when I moved him into the bubble bucket for the first time I burned them so I cut back on nutes and mabey I went to low on the micro? I’m still trying to figure this thing out what’s the best way to get back right. My ppm is 400 pH is spot on at 5.8 it’s my first time Hydro and even with this little problem its been some of the most amazing growth I’ve ever seen


#4

If you want a blanket solution, fill a fine mesh bag with Azomite, a volcanic clay they mine in Utah. It has all the micro nutrients that your plants need and the bag just gets dropped into your buckets and forgotten.
I’ve seen explosive root growth using it and great roots equals healthy plants.
Don’t bother buying the food grade of Azomite (yes even people eat this stuff), it’s ten times more expensive. I get 30 lb bags of it at a farm supply store for under $30 and you only need a handful per bucket/bag.


#5

This post was flagged by the community and is temporarily hidden.