Help, 10 weeks into flowering


#1

Hb 818


#2

What is the question?


#3

Pistols are still clear


#4

They don’t look right to me. And it’s been 12/12 for 10 weeks


#5

Yeah I would guess I give a week or two and just keep checking. the Last two pics I see cob webs on the plant check for critters.


#6

Thanks, will do


#7

Looks like it had a major lack of lighting by the stretched out node spacing. Also is probably why it’s not progressing very fast. But you didn’t provide much info to go off of.


#8

That’s it, I’m using 250w hps, and ran a metal halide for the vegetation.

What are your thoughts on 24/24 for the first 4 weeks?


#9

Thanks by the way.


#10

I’m not an expert. But it seems most people agree that plants need a rest break. I think the only ones I’ve seen going 24 was only for the first week or two at most. After that 18/6 then 12/12 for flower. 250 watts for a single plant? That should’ve been ok unless your light was way high above the plant.


#11

It looks like you have spider mites from those pics. Better get some magnification on those leaves. If your plant is under attack it may be causing the lack of bud developmen if its trying to deal with those things too. But It does look like insufficient lighting to me as well. Good luck keep us posted​:v::+1:


#12

Looks like you’ve done well getting this close to harvest. I think you can do even better.

I suggest you follow the below link, fill out the “support ticket”, post it back here and hopefully some of the expert growers here can help you improve your result. Without knowing more about your grow, it’s hard to offer good suggestions,. For instance, I suspect you don’t have a fan blowing on your plant … but I could be wrong. The spindly stems and need to tie it off to supports both suggest no fan. But there could be other reasons.