Everything was going perfect and then leaves started to turn

I am growing 2 autos in dwc. Seed are from ilgm. It is under a marz hydro TSL 2000 @ 22 inches. I use the Flora trio with cal-mag and hydrogaurd. 3 days ago I noticed some leaves were not all green. Only the new growth. I checked everything. Ppm was 900 and 5.9 ph.now it looks bad. I turned the light down to 75%. I did a bucket clean and gave them last weeks feeding schedule. And I went out and bought distilled water. Instead of my tap water that I de chlorinated. I think I may have an iron deficiency. And I noticed some light burn.


So I have a few questions? Should I get rid of the bad leaves? Has anyone else delt with this? How did you fix it and can it be fixed. I think I just started to flower also. What timing right. I recalibrate my ppm and ph pens for good measure. Let me know smarter people then me if you need more info. And thanks

1 Like

Some leaves bounce back from nute deficiency but there are others that are just a
“OOPS and clip it” type mistake. I’m not a Hydro guy so someone else with hydro
experience will have to chime in.

2 Likes

Looks like cal mag deficiency to me and the yellowing might reverse but the damage is minor enough to leave the leaves on.

3 Likes

Nice looking plants spread out even canopy, I am not a hydro guy. But The rusty spots on the leafs I’m with @GreenSnek looks like early cal mag deficiency.
Good luck

3 Likes

How far into it are u. Hell u can prolly strip off quite a few of the big leaves and open that baby up some get some air and light thru the mod of the plant. I do autos and i strip them down quite a bit 21 and r2 dayinto flower. Just stripped 2 w.w. autos last noght and tgey havnt skipped a beat. They r standing beautiful and look as they r filling in already.

2 Likes

How much is your light turned up? How close was it, and did you move it up recently?

1 Like

Yes I moved it up to 24 inches. And turned it down from 100% to 75% it was 18 inches above. I am going to strip it tonight.

1 Like

I am on day 48 @Mark0427

2 Likes

Reason I asked, is because it looks like light burn. So since you raised it, i think you’re okay now.

2 Likes

In what order do you mix your nutes?
How often are you using calmag?

They look a little hungry to me. IMO, you don’t have anything to worry about.
It’s quite common to have light green leaves on the new growth, especially when they wake up.
Plants overall look fabulous. :+1:t2::sunglasses:

1 Like

I was doing the micro first. But now since I am useing distilled water I am doing cal-mag first. I was tring to do 300 ppm to make sure I have enough. And I dont put in water without nutes. Before I add water in between cleanouts I check my ppm. If it is less then the start I will bump it up. I want it to be abought the same. But running 2 different autos they eat different. But the next time I run then I should be better off. I gave them a nice trim and had to move light up to 28 inches at 70%. I hope that will stop the light burn. I am running out of room to move up. And was told to be running this led at 100%. And like 12-18 inches. There is no way they would cook.

2 Likes

Nicely done :+1:t2: I would just keep on doing what your doing. Plants look good. Just watch the new growth. In dwc always add calmag first.:v::+1:t2::sunglasses:

1 Like

Thks @spyonyou.

1 Like